Задание 06. Определение результатов работы простейших алгоритмов

Печать

Рейтинг: 5 / 5

Звезда активнаЗвезда активнаЗвезда активнаЗвезда активнаЗвезда активна
 

ВАРИАНТ 1

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост поднят. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n  — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m  —  целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Опусти, принуждающая Черепаху опустить хвост.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм: 

Вперед 100 Направо 90 Вперед 100 Направо 30 Опусти
Повтори 10 [Вперёд 25 Направо 90].

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует.

Решение и ответ
 

count = 0
k = 3**0.5

for x in range(75,125):
    for y in range(50,100):
        if (k*x + (1-k)*100 - 50) < y < (k*x + (1-k)*100)  and (-x/k + (1+1/k)*100 - 50/k) < y < (-x/k + (1+1/k)*100):
            count +=1      

print (count)

Ответ625

ВАРИАНТ 2

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост поднят. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n  — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m  —  целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Опусти, принуждающая Черепаху опустить хвост.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм: 

Вперед 100 Направо 90 Вперед 100 Направо 45 Опусти
Повтори 10 [Вперёд 30 Направо 90].

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует.

Решение и ответ

count = 0

for x in range(50,150):
    for y in range(50,100):
        if x - 30 * 2**0.5 < y < x  and -x + 200 - 30*2**0.5 < y < -x+ 200:
            count +=1   

print (count)

Ответ: 882

ВАРИАНТ 3

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост поднят. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n  — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m  —  целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Опусти, принуждающая Черепаху опустить хвост.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм: 

Вперед 100 Направо 90 Вперед 100 Направо 30 Опусти
Повтори 10 [Вперёд 30 Направо 90 
Вперёд 40 Направо 90].

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует.

Решение и ответ

Решение аналогично первому варианте, но:

смещение второй прямой равно 30 :  Sin 30o = 30 : 1/2 = 60
смещение четвертой прямой равно 40 :  Сos 30o = 40 : √3/2 = 80/√3

 

count = 0
k = 3**0.5
for x in range(50,150):
    for y in range(50,100):
        if (k*x + (1-k)*100 - 60) < y < (k*x + (1-k)*100)  and (-x/k + (1+1/k)*100 - 80/k) < y < (-x/k + (1+1/k)*100):
            count +=1     

 

print (count)

Ответ: 1200

ВАРИАНТ 4

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост поднят. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n  — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m  —  целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Опусти, принуждающая Черепаху опустить хвост.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм: 

Вперед 100 Направо 90 Вперед 100 Направо 45 Опусти
Повтори 10 [Вперёд 30 Направо 90].

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует. 

Решение и ответ

Решение аналогично второму варианту, но:

смещение второй прямой равно 20 :  Sin 45o = 20 : 1/√2 = 20√2

count = 0
k = 3**0.5

for x in range(50,150):
    for y in range(50,100):
        if x - 20 * 2**0.5 < y < x  and -x + 200 - 30*2**0.5 < y < -x+ 200:
            count +=1   

print (count)

Ответ588

ВАРИАНТ 5

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост поднят. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n  — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m  —  целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Опусти, принуждающая Черепаху опустить хвост.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм: 

Повтори 11 [Вперёд 111 Направо 120].

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует. 

Решение и ответ

count = 0

k = 3**0.5
for x in range(1,120):
    for y in range(1,120):
        if x/k < y < -x/k + 111:
            count +=1     

print (count)

 Ответ: 5280

ВАРИАНТ 6

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост поднят. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n  — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m  —  целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Опусти, принуждающая Черепаху опустить хвост.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм: 

Повтори 10 [Вперёд 123 Направо 120].

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует.

Решение и ответ

Решение аналогично варианту 5.

count = 0
k = 3**0.5
for x in range(1,120):
    for y in range(1,123):
        if x/k < y < -x/k + 123:
            count +=1

print (count)

Ответ: 6488

ВАРИАНТ 7

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост поднят. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n  — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m  —  целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Опусти, принуждающая Черепаху опустить хвост.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм: 

Повтори 21 [Вперёд 31 Направо 60].

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует. 

Решение и ответ

count = 0
k = 3**0.5

for x in range(1,54):
    for y in range(-31,47):
        if -x/k < y < x/k + 31  and x/k -31 < y < -x/k + 62:
            count +=1  

print (count)

Ответ: 2476

ВАРИАНТ 8

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост поднят. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n  — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m  —  целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Опусти, принуждающая Черепаху опустить хвост.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм: 

Повтори 18 [Вперёд 19 Направо 60].

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует. 

Решение и ответ

Решение аналогично варианту 7.

count = 0
k = 3**0.5
for x in range(1,33):
    for y in range(-19,29):
        if -x/k < y < x/k + 19  and x/k -19 < y < -x/k + 38:
            count +=1        

print (count)

Ответ: 922

ВАРИАНТ 9

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост поднят. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n  — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m  —  целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Опусти, принуждающая Черепаху опустить хвост.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм: 

Направо 30 Повтори 10 [Вперёд 30 Направо 60 Вперед 30 Направо 120].

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует. 

Решение и ответ

count = 0
k = 3**0.5
for x in range(1,45):
    for y in range(1,26):
        if k*x -30*k < y < k*x:
            count +=1

print (count)

Ответ: 750

ВАРИАНТ 10

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост поднят. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n  — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m  —  целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Опусти, принуждающая Черепаху опустить хвост.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм: 

Повтори 10 [ Направо 120 Вперед 12 Направо 60 Вперёд 12].

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует. 

Решение и ответ

count = 0
k = 3**0.5
for x in range(1, 11):
    for y in range(-18,0):
        if -1/k*x - 12 < y < -1/k*x:
            count +=1        

print (count)

Ответ: 120

ВАРИАНТ 11

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост поднят. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n  — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m  —  целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Опусти, принуждающая Черепаху опустить хвост.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм: Направо 180 Вперед 2 Направо 90 Вперед 30 Направо 90 Вперед 2 Направо 30 Повтори 6 [ Вперед 5 Направо 120 Вперед 5 Направо 240].

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует.  

Решение и ответ

Рисунок получился небольшой, сетка 1:1, в каждой из 5-ти областей - треугольнике и части прямоугольника по 17 точек, в последнем - 16. Получим 17* 5 + 16 = 101.

Ответ: 101

ВАРИАНТ 12

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост поднят. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n  — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m  —  целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Опусти, принуждающая Черепаху опустить хвост.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм: Направо 10 Вперед 4 Направо 90 Вперед 48 Направо 90 Вперед 4 Направо 30 Повтори 8 [ Вперед 6 Направо 120 Вперед 6 Направо 240].

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует.  

Решение и ответ

В каждом треугольнике 49 точек. Всего 8*40 = 320.

Ответ: 320

ВАРИАНТ 13

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост поднят. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n  — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m  —  целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Опусти, принуждающая Черепаху опустить хвост.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм: Направо 60 Повтори 4 [ Вперед 8 Направо 120 Вперед 4 Направо 240
Направо 120 Вперед 2 Направо 90 Вперед 16√3 Направо 90 Вперед 2 .

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует.  

Решение и ответ

Фигура небольшая, поэтому самый быстрый способ, это увеличить масштаб в КУмире и посчитать точки с целочисленными координатами.

 

Ответ: 91

ВАРИАНТ 14

 Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост поднят. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n  — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m  —  целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Опусти, принуждающая Черепаху опустить хвост.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм: Направо 60 Повтори 3 [ Вперед 10 Направо 120 Вперед 5 Направо 240
Направо 120 Вперед 3 Направо 90 Вперед 15√3 Направо 90 Вперед 3 .

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует.

Решение и ответ

 

Ответ: 125

ВАРИАНТ 15

Исполнитель Цапля действует на плоскости с декартовой системой координат. В начальный момент Цапля находится в начале координат, её клюв направлен вдоль положительного направления оси ординат, клюв опущен.При опущенном клюве Цапля оставляет на поле след в виде линии.В каждый конкретный момент известно положение исполнителя и направление его движения.У исполнителя существует три команды: Вперёд n (где n - целое число),вызывающая передвижение Цапли на n единиц в том направлении, куда указывает ее клюв;Направо m (где m - целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Дуга r,a,b,α (где r,a,b,α - целые числа), вызывающая передвижение Цапли из текущей точки с координатами (х,y)по дуге окружности с центром (x + a, y + b) и радиусом r, градусная мера дуги равна α, движение по дуге идет по часовой стрелке. 

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Цапле был дан для исполнения следующий алгоритм: Направо 180 Вперед 2 Направо 90 Вперед 80 Направо 90 Вперед 2 Повтори 8 [Дуга 5, 5, 0, 180] .

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует.  

 

 

Решение и ответ

В каждой области 48 точек и 7 между границами. Получим 48* 8 + 7 = 391.

Ответ: 391

ВАРИАНТ 16

Исполнитель Цапля действует на плоскости с декартовой системой координат. В начальный момент Цапля находится в начале координат, её клюв направлен вдоль положительного направления оси ординат, клюв опущен.При опущенном клюве Цапля оставляет на поле след в виде линии.В каждый конкретный момент известно положение исполнителя и направление его движения.У исполнителя существует три команды: Вперёд n (где n - целое число),вызывающая передвижение Цапли на n единиц в том направлении, куда указывает ее клюв;Направо m (где m - целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Дуга r,a,b,α (где r,a,b,α - целые числа), вызывающая передвижение Цапли из текущей точки с координатами (х,y)по дуге окружности с центром (x + a, y + b) и радиусом r, градусная мера дуги равна α, движение по дуге идет по часовой стрелке. 

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Цапле был дан для исполнения следующий алгоритм: Направо 180 Вперед 3 Направо 90 Вперед 48 Направо 90 Вперед 3 Повтори 6 [Дуга 4, 4, 0, 180] .

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует. 

Решение и ответ

 

В каждой области 40 точек и 10 между границами. Получим 40*6 + 10 = 250.

Ответ: 250

ВАРИАНТ 17

Исполнитель Цапля действует на плоскости с декартовой системой координат. В начальный момент Цапля находится в начале координат, её клюв направлен вдоль положительного направления оси ординат, клюв опущен.При опущенном клюве Цапля оставляет на поле след в виде линии.В каждый конкретный момент известно положение исполнителя и направление его движения.У исполнителя существует три команды: Вперёд n (где n - целое число),вызывающая передвижение Цапли на n единиц в том направлении, куда указывает ее клюв;Направо m (где m - целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Дуга r,a,b,α (где r,a,b,α - целые числа), вызывающая передвижение Цапли из текущей точки с координатами (х,y)по дуге окружности с центром (x + a, y + b) и радиусом r, градусная мера дуги равна α, движение по дуге идет по часовой стрелке. 

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Цапле был дан для исполнения следующий алгоритм: Повтори 7
[
Дуга 4, 0, 4, 180
Дуга 4, 4, 0, 180
Дуга 4, 0, -4, 180
Дуга 4, -4, 0, 180].

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует. 

 

Решение и ответ

 

Получим, четыре полуокружности, в каждой по 19 точек, и квадрат без углов, ( 9*9 - 4 = 77 точек). Всего 153.

Ответ: 153

ВАРИАНТ 18

Исполнитель Цапля действует на плоскости с декартовой системой координат. В начальный момент Цапля находится в начале координат, её клюв направлен вдоль положительного направления оси ординат, клюв опущен.При опущенном клюве Цапля оставляет на поле след в виде линии.В каждый конкретный момент известно положение исполнителя и направление его движения.У исполнителя существует три команды: Вперёд n (где n - целое число),вызывающая передвижение Цапли на n единиц в том направлении, куда указывает ее клюв;Направо m (где m - целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Дуга r,a,b,α (где r,a,b,α - целые числа), вызывающая передвижение Цапли из текущей точки с координатами (х,y)по дуге окружности с центром (x + a, y + b) и радиусом r, градусная мера дуги равна α, движение по дуге идет по часовой стрелке. 

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Цапле был дан для исполнения следующий алгоритм:
Направо 180 Вперед 3
Направо 90 
Вперед 48 
Направо 90 Вперед 3 

Повтори 7
Дуга 4, 0, 4, 180
Дуга 4, 4, 0, 180
Дуга 4, 0, -4, 180
Дуга 4, -4, 0, 180

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует. 

Решение и ответ

Если я правильно поняла задание, то замкнутой области не получится...

Ответ: ?

ВАРИАНТ 19

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост поднят. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n  — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m  —  целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Опусти, принуждающая Черепаху опустить хвост.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм: Направо 300 Повтори 8 [ Вперед 10 Направо 120 Вперед 10 Направо 330].

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует.

Решение и ответ

Рисунок получился небольшой, сетка 1:1,  5 областей - 4  треугольника по 47 точек и квадрат посередине из 81 точки.
Получим 47* 4 + 81 = 269.

Ответ: 269

ВАРИАНТ 20

Исполнитель Черепаха действует на плоскости с декартовой системой координат. В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост поднят. При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n  — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова, и Направо m (где m  —  целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Опусти, принуждающая Черепаху опустить хвост.

Запись Повтори k [Команда1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм: Направо 300 Повтори 6 [ Вперед 5 Направо 120 Вперед 5 Направо 330].

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует.

Решение и ответ

Рисунок получился небольшой, сетка 1:1,  5 областей - 4  треугольника по 12 точек и квадрат посередине из 16 точек.

Получим 12* 4 + 16 = 64.

Ответ: 64