Задание 08. Перебор слов и системы счисления

Печать

Рейтинг: 5 / 5

Звезда активнаЗвезда активнаЗвезда активнаЗвезда активнаЗвезда активна
 

ВАРИАНТ 1

Определите количество пятизначных чисел, записанных в восьмеричной системе счисления, в записи которых ровно две цифры 4, и при этом никакая нечетная цифра не стоит рядом с цифрой 4.

Решение и ответ
""
* * * * * - пятизначное число
N : {0, 1, 2, 3, 4, 5, 6, 7} В алфавите 8 чисел
Nc: {1, 3, 5, 7} - нечетные числа
Ch: {0, 2, 4, 6} - четные числа

Рядом с цифрой 4 может стоять только четное число, кроме 4. 
То есть 0, 2, или 6. При этом 0 не может быть на первом месте.

44*** - 3*7*7 (первая звездочка может примать одно из 3-х значений, вторая, одно из семи, третья тоже одно из семи, по правилу произведения, получим 147 вариантов)
4*4** - 3*3*7
4**4* - 3*3*3
4***4  - 3*7*3
*44** - 2*3*7
*4*4* - 2*3*3
*4**4 - 2*3*3
**44* - 6*3*3
**4*4 - 6*3*3
***44 - 6*7*3
"""

print (3*7*7 +  3*3*7 + 3*3*3 + 3*7*3 + 2*3*7 + 2*3*3*2 + 6*3*3*2 + 6*7*3)

Ответ612

ВАРИАНТ 2

Определите количество пятизначных чисел, записанных в четверичной системе счисления, в записи которых ровно одна цифра 3, и при этом цифра 0 не стоит рядом с цифрой 3.

Решение и ответ
 """
* * * * * - пятизначное число
N : {0, 1, 2, 3} - в алфавите 4 числа
Цифра 3 может быть только одна. При этом 0 не стоит рядом с 3.

3**** - 2*3*3*3 (первая звездочка может быть единицей или двойкой, вторая, третья и четвертая могут принимать одно из трех значений, по правилу произведения получим  54 варианта)

*3*** - 2*2*3*3
**3** - 2*2*2*3
***3* - 2*3*2*2
****3 - 2*3*3*2

"""

print (2*3*3*3 + 2*2*3*3 + 2*2*2*3 + 2*3*2*2 + 2*3*3*2)

Ответ:174

ВАРИАНТ 3

Все шестибуквенные слова, в составе которых могут быть только русские буквы С, О, Р, Н, Я, К записаны в алфавитном порядке и пронумерованы начиная с 1. 

Гиже приведено начало списка.

1. КККККК
2. КККККН
3. КККККО
4. КККККР
5. КККККС
6. КККККЯ
7. ККККНК
....

Под каким номером в списке идет первое слово, которое содержит не более трех букв К и ровно две буквы Я?

Решение и ответ
Представим буквы в шестиричной системе счисления, тогда К=0, Н=1, О=2, Р=3, С=4, Я=5.

Первое слово, в котором не более трех К и ровно две Я, это: 000155, то есть КККНЯЯ.

Переведем 155 в десятичную систему счисления и прибавим 1, так как первое слово равно 0.

 print( int('155', 6) +1)

Ответ:72

ВАРИАНТ 4

Все шестибуквенные слова, в составе которых могут быть только русские буквы П, О, Л, Ь, З, А записаны в алфавитном порядке и пронумерованы начиная с 1. 

Гиже приведено начало списка.

1. АААААА
2. АААААЗ
3. АААААЛ
4. АААААО
5. АААААП
6. АААААЬ
7. ААААЗА
....

Под каким номером в списке идет первое слово, которое содержит не более одной буквы Ь, ровно одну букву А и не более двух букв З?

Решение и ответ
Представим буквы в шестиричной системе счисления, тогда А=0, З=1, Л=2, О=3, П=4, Ь=5.

Первое слово, в котором одна А и не более двух З, и не более одного Ь, это:
011222, то есть АЗЗЛЛЛ. Не более одного Ь означает что его может не быть, так как мы ищем наименьшее число в списке.

Переведем 11222 в десятичную систему счисления и прибавим 1, так как первое слово равно 0.

print( int('11222', 6) +1)

Ответ: 1599

ВАРИАНТ 5

Все четырехбуквенные слова, в составе которых могут быть только русские буквы А, Т, О, М записаны в алфавитном порядке и пронумерованы начиная с 1. 

Гиже приведено начало списка.

1. АААА
2. АААМ
3. АААО
4. АААТ
5. ААМА
6. ААММ
....

Под каким номером в списке идет первое слово, которое начинается с буквы О?

Решение и ответ
аналогично вариантам 3, 4

 Ответ: 129

ВАРИАНТ 6

Все четырехбуквенные слова, в составе которых могут быть только русские буквы П, Р, А, В, О записаны в алфавитном порядке и пронумерованы начиная с 1. 

Гиже приведено начало списка.

1. АААА
2. АААВ
3. АААО
4. АААП
5. АААР
6. ААВА
7. ААВВ
....

Под каким номером в списке идет первое слово, которое начинается с буквы П?

Решение и ответ
  аналогично вариантам 3, 4

Ответ: 376

ВАРИАНТ 7

Все пятибуквенные слова, в составе которых могут быть только русские буквы М, А, С, Л, О записаны в алфавитном порядке и пронумерованы начиная с 1. 

Гиже приведено начало списка.

1. ААААА
2. ААААЛ
3. ААААМ
4. ААААО
5. ААААС
6. АААЛА
....

Под каким номером в списке идет первое слово, которое которое содержит не более одной буквы А, ровно две буквы М и не содержит ни одной Л?

Решение и ответ
  аналогично вариантам 3, 4

Ответ: 319

ВАРИАНТ 8

Все шестибуквенные слова, в составе которых могут быть только русские буквы В, А, Л, И, К записаны в алфавитном порядке и пронумерованы начиная с 1. 

Гиже приведено начало списка.

1. АААААА
2. АААААВ
3. АААААИ
4. АААААК
5. АААААЛ
6. ААААВА
....

Под каким номером в списке идет первое слово, которое содержит не более двух букв А, ровно две буквы В и не содержит ни одной буквы И?

Решение и ответ
аналогично вариантам 3, 4

Ответ: 169 

ВАРИАНТ 9

Сколько существует различных трехзначных чисел, записанных в четверичной системе счисления, в записи которых цифры следуют слева направо в строго убывающем порядке? 

Решение и ответ

Алфавит четверичной системы счисления: {0, 1, 2, 3}

Это числа: 321, 320, 310, 210

Ответ: 4

ВАРИАНТ 10

Сколько существует различных трехзначных чисел, записанных в пятиричной системе счисления, в записи которых цифры следуют слева направо в строго убывающем порядке? 

Решение и ответ

Алфавит пятиричной системы счисления: {0, 1, 2, 3, 4}

Это числа: 432, 431, 430, 421, 420, 410, 321, 320, 310, 210

Ответ: 10

ВАРИАНТ 11

Сколько существует различных трехзначных чисел, записанных в четверичной системе счисления, в записи которых цифры следуют слева направо в невозрастающем порядке? 

Решение и ответ

Алфавит четверичной системы счисления: {0, 1, 2, 3}

Это числа: 
333, 332, 331, 330, 322, 321, 320, 311, 310, 300
222, 221, 220, 211, 210, 200
111, 110, 100

import itertools
N = '0123'
a = []

for i in itertools.product(N, repeat=3): 
    if  i[0] != '0' and int(i[0]) >= int(i[1]) >= int(i[2]):
        a.append(i)
        print(*i)
print(len(a))

Ответ: 19

ВАРИАНТ 12

Сколько существует различных трехзначных чисел, записанных в пятиричной системе счисления, в записи которых цифры следуют слева направо в невозрастающем порядке? 

Решение и ответ

import itertools
N = '01234'
a = []

for i in itertools.product(N, repeat=3):    
    if  i[0] != '0' and int(i[0]) >= int(i[1]) >= int(i[2]):
        a.append(i)
        print(*i)

print(len(a))

Ответ: 34

ВАРИАНТ 13

Сколько существует различных четырехзначных чисел, записанных в восьмеричной системе счисления, в записи которых есть ровно две одинаковые цифры, стоящие рядом?

Решение и ответ
"""
* * * *  - четырехзначное число
N : { 0, 1, 2, 3, 4, 5 , 6, 7 } - в алфавите 8 цифр
Ровно две одинаковые цифры, стоящие рядом  - это:

11** - 7*6 (первая звездочка может примать одно из 7 значений, вторая, одно из шести, по правилу произведения, получим 42 варианта)
*11* - 6*6
**11 - 6*6

Таких вариантов всего (42 + 36 + 36) * 7 для всех цифр кроме 0

Ноль не может быть первым символом:
*00* - 7*6
**00 - 7*6
"""

print ((42 + 36 + 36) * 7 + 42*2)

Ответ: 882

ВАРИАНТ 14

Сколько существует различных четырехзначных чисел, записанных в десятичной системе счисления, в записи которых есть ровно две одинаковые цифры, причем стоящие рядом?

Решение и ответ
"""

* * * *  - четырехзначное число
N : { 0, 1, 2, 3, 4, 5 , 6, 7, 8, 9} - в алфавите 10 цифр
Ровно две одинаковые цифры, стоящие рядом  - это:

11** - 9*8 (первая звездочка может примать одно из 9 значений, вторая, одно из восьми, по правилу произведения, получим 72 варианта)
*11* - 8*8
**11 - 8*8

Таких вариантов всего (72 + 64 + 64) * 9 для всех цифр кроме 0

Ноль не может быть первым символом:
*00* - 9*8
**00 - 9*8
"""

print ((72 + 64 + 64) * 9 + 72*2)

Ответ: 1944

ВАРИАНТ 15

Шифр кодового замка представляет собой последовательность из пяти символов, каждый из которых является цифрой от 1 до 6. Сколько различных вариантов шифра можно задать, если известно, что цифра 1 должна встречаться в коде ровно 1 раз, а каждая из других допустимых цифр может встречаться в коде любое количество раз или не встречаться совсем?
 
Решение и ответ

***** - шифр
N: {1, 2, 3, 4, 5, 6}
Цифра 1 может стоять на одной из трех позиций шифра - 5 вариантов
Остальные четыре позиции могут быть одной из пяти оставшихся цифр.

По правилу произведения, получим: 5 * 54

Ответ: 3125

ВАРИАНТ 16

Шифр кодового замка представляет собой последовательность из трех символов, каждый из которых является цифрой от 1 до 4. Сколько различных вариантов шифра можно задать, если известно, что цифра 2 должна встречаться в коде ровно 1 раз, а каждая из других допустимых цифр может встречаться в шифре любое количество раз или не встречаться совсем?

 
Решение и ответ

*** - шифр
N: {1, 2, 3, 4}
Цифра 2 может стоять на одной из трех позиций шифра - 3 варианта
Остальные две позиции могут быть одной из трех  оставшихся цифр.
По правилу произведения, получим: 3 * 32

Ответ: 27

ВАРИАНТ 17

Шифр кодового замка представляет собой последовательность из четырех символов, каждый из которых является цифрой от 1 до 5. Сколько различных вариантов шифра можно задать, если известно, что цифра 5 должна встречаться в коде ровно 1 раз, а каждая из других допустимых цифр может встречаться в шифре любое количество раз или не встречаться совсем?

 
Решение и ответ
аналогично вариантам 15 и 16

Ответ: 256

ВАРИАНТ 18

Шифр кодового замка представляет собой последовательность из шести символов, каждый из которых является одной из букв А, В или С. Сколько различных вариантов шифра можно задать, если известно, что буква А должна встречаться в коде ровно 1 раз, а каждая из других допустимых букв может встречаться в шифре любое количество раз или не встречаться совсем?

Решение и ответ
аналогично вариантам 15 и 16

Ответ: 192

ВАРИАНТ 19

Шифр кодового замка представляет собой последовательность из пяти символов, каждый из которых является одной из букв X, Y или Z. Сколько различных вариантов шифра можно задать, если известно, что буква X должна встречаться в коде ровно 2 раза, а каждая из других допустимых букв может встречаться в шифре любое количество раз или не встречаться совсем?

Решение и ответ

***** - шифр
N: {X, Y, Z}
XX***
X*X**
X**X*
...таких сочетаний получим 5!/(2!*3!) = 10
Остальные три позиции могут быть одной из двух оставшихся букв.
По правилу произведения, получим: 10 * 23

Ответ: 80

ВАРИАНТ 20

Шифр кодового замка представляет собой последовательность из четырех символов, каждый из которых является одной из букв А, В, С или D. Сколько различных вариантов шифра можно задать, если известно, что буква А должна встречаться в коде ровно 2 раза, а каждая из других допустимых букв может встречаться в шифре любое количество раз или не встречаться совсем?

Решение и ответ
аналогично варианту 19

Ответ: 54