Задание 14. Арифметические выражения

Рейтинг: 3 / 5

Звезда активнаЗвезда активнаЗвезда активнаЗвезда не активнаЗвезда не активна
 

ВАРИАНТ 1

Значение арифметического выражения:
4 *2
52022 - 2 * 52000 + 1251011 - 3 * 5100 - 660
записали в системе счисления с основанием 5.
Сколько цифр "
4" содержится в этой записи?

Решение и ответ
 

x = 4*25**2022 - 2 *5**2000 + 125**1011 - 3 * 5**100 - 660
k = 0
while x > 0:
    if x % 5 == 4:
         k += 1
    x = x // 5
print  (k)

Ответ: 3028 

ВАРИАНТ 2

Значение арифметического выражения: 
4
2022 - 6 * 4522 + 5 * 64510 - 3 * 2330 - 100
записали в системе счисления с основанием 8.
Сколько цифр "
7" содержится в этой записи?

Решение и ответ
 

x = 4**2022 - 6 *4**522 + 5*64**510 - 3 * 2**330 - 100
k = 0
while x > 0:
    if x % 8 == 7:
         k += 1
    x = x // 8
print  (k)

Ответ: 1015

ВАРИАНТ 3

Значение арифметического выражения:
243
540 - 6 * 9530 + 21 * 3511 - 3 * 370 - 200
записали в системе счисления с основанием 9.
Сколько цифр "
8" содержится в этой записи?

Решение и ответ
 

решение аналогично варианту 1,2

Ответ: 1071

ВАРИАНТ 4

Значение арифметического выражения: 
1331
650 - 55 * 121610 + 77 * 11510 - 3 * 11100 - 221
записали в системе счисления с основанием 11.
Сколько цифр "А" содержится в записи этого числа?

Решение и ответ
 

x = 1331**650 - 55 *121**610 + 77*11**510 - 3 * 11**100 - 221
k = 0
while x > 0:
    if x % 11 == 10:
         k += 1
    x = x // 11
print  (k)

Ответ1236

ВАРИАНТ 5

Значение арифметического выражения: 
52022 - 2 * 51010 + 25850 + 2500 
записали в системе счисления с основанием 5.

Сколько цифр "4" содержится в этой записи?

Решение и ответ

x = 5**2022 - 2 *5**1010 + 25**850 + 2500
k = 0
while x > 0:
    if x % 5 == 4:
         k += 1
    x = x // 5
print  (k)

 Ответ690

ВАРИАНТ 6

Значение арифметического выражения: 
42022 - 2 * 41111 + 16600 + 192 
записали в системе счисления с основанием 
4.

Сколько цифр "3" содержится в этой записи?

Решение и ответ

аналогично 5

Ответ: 89

ВАРИАНТ 7

Значение арифметического выражения: 
2 * 32022 + 5 * 31800 + 31001 + 4 * 31000 + 3 
записали в системе счисления с основанием 
9.

Сколько  значащих нулей содержится в этой записи?

Решение и ответ

аналогично 5

Ответ: 1008

ВАРИАНТ 8

Значение арифметического выражения: 
32021 + 5 * 32000 + 3501 + 5 * 3500 + 1
записали в системе счисления с основанием 9.

Сколько  значащих нулей содержится в этой записи?

Решение и ответ

аналогично 5

Ответ: 1007

ВАРИАНТ 9

Значение арифметического выражения: 
52019 - 51019 + 25600 - 125
записали в системе счисления с основанием 5.

Сколько цифр "4" содержится в этой записи?

Решение и ответ

аналогично 5

Ответ: 1196

ВАРИАНТ 10

Значение арифметического выражения: 
32020 - 31020 + 9800 - 81 
записали в системе счисления с основанием 3.

Сколько цифр "2" содержится в этой записи?

Решение и ответ

аналогично 5

Ответ: 1595

ВАРИАНТ 11

Значение арифметического выражения: 
4700 + 4100 - 16100 - 64 
записали в системе счисления с основанием 4.

Сколько цифр "3" содержится в этой записи?

Решение и ответ

аналогично 5

Ответ: 597

ВАРИАНТ 12

Значение арифметического выражения: 
3
333 + 322 - 9111 - 8 
записали в системе счисления с основанием 3.

Сколько цифр "2" содержится в этой записи?

Решение и ответ

аналогично 5

Ответ: 131

ВАРИАНТ 13

Операнды арифметического выражения записаны в системе счисления с основанием 15.

135x715  + 7x53115

В записи чисел переменной x обозначена неизвестная цифра из алфавита 15-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 1410.

 

Для найденного значения x вычислите частное от деления значения арифметического выражения на 1410 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.

Решение и ответ

for x in '0123456789ABCDE':
    a = '135'+ str (x) + '7'
    b = '7' + str (x) + '531'
    c = int (a,15)+ int (b,15)
    if c % 14 == 0:
        print (c//14)
        break

Ответ: 31027

ВАРИАНТ 14

 

Операнды арифметического выражения записаны в системе счисления с основанием 15.

135x917  + 9x53117

В записи чисел переменной x обозначена неизвестная цифра из алфавита 17-ричной системы счисления. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 910.

Для найденного значения x вычислите частное от деления значения арифметического выражения на 910 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.

Решение и ответ

for x in '0123456789ABCDEFG':
    a = '135'+ str(x) + '9'
    b = '9' + str(x) + '531'
    c = int(a,17)+ int(b,17)
    if c % 9 == 0:
        print(c//9)

Ответ: 101340

ВАРИАНТ 15

Операнды арифметического выражения записаны в системе счисления с основанием 21.

12yx921  + 36y9921

В записи чисел переменными x и у обозначены неизвестные цифры из алфавита
21-ричной системы счисления.

Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 1810 при любом значении у.

Для найденного значения x вычислите частное от деления значения арифметического выражения на 1810 при у = 5 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.

Решение и ответ

for x in '0123456789ABCDEFGHIJK':
    ok = True
    for y in '0123456789ABCDEFGHIJK':
        a = '12'+ y + x + '9'
        b = '36' + y + '99'
        if (int(a,21)+ int(b,21)) % 18 != 0:
            ok = False
    if ok:
        a = '125' + x + '9'
        b = '36599'
        print((int (a, 21)+int (b, 21)) // 18)
        break

Ответ: 47594

ВАРИАНТ 16

Операнды арифметического выражения записаны в системе счисления с основанием 26.

13yx526  + 24y1326

В записи чисел переменными x и у обозначены неизвестные цифры из алфавита
26-ричной системы счисления.Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 810 при любом значении у.

Для найденного значения x вычислите частное от деления значения арифметического выражения на 810 при у = 2 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.

 

Решение и ответ

for x in '0123456789ABCDEFGHIJKLMNOP':
    ok = True
    for y in '0123456789ABCDEFGHIJKLMNOP':
        a = '13'+ y + x + '5'
        b = '24' + y + '13'
        if (int(a,26)+ int(b,26)) % 8 != 0:
            ok = False
    if ok:
        a = '132' + x + '5'
        b = '24213'
        print((int(a,26)+int(b,26))//8)

Ответ: 187162

ВАРИАНТ 17

Значение арифметического выражения: 
7
80 + 4915 - 49
записали в системе счисления с основанием 7.

Сколько цифр "6" содержится в этой записи?

 

Решение и ответ

x = 7**80 + 49**15 - 49
k = 0

while x > 0:
    if x % 7 == 6:
         k += 1
    x = x // 7
print  (k)

Ответ: 28

ВАРИАНТ 18

Значение арифметического выражения: 
5
28 + 256 - 125
записали в системе счисления с основанием 5.

Сколько цифр "4" содержится в этой записи?

Решение и ответ

аналогично варианту 17

Ответ: 9

ВАРИАНТ 19

Значение арифметического выражения: 
3
2017 + 91000 - 27 
записали в системе счисления с основанием 
3.

Сколько цифр "2" содержится в этой записи?

Решение и ответ

аналогично варианту 17

Ответ: 1997

ВАРИАНТ 20

Значение арифметического выражения:
3
2017 + 91000 + 9100- 81 
записали в системе счисления с основанием 
3.

Сколько цифр "2" содержится в этой записи?

Решение и ответ

аналогично варианту 17

Ответ: 196

Добавить комментарий


РСЯ футер

© 2017 Компьютерный клуб "КОД". Все права защищены.